Running Fess as service


I tried to install fess to run as service in windows server 2012 R2 -
I ran “service.bat install” and got message:
“The service ‘fess-service-x64’ has been installed”
I started this win service, but couldn’t connect to web interface (http://localhost:8080)

But if i start fess by running “fess.bat” it works ok and i can connect to web UI

Is it possible to run fess as a service?

Could you check log files in logs folder?

In fess-service-x64.YYYY-MM-DD.log:

[2016-09-30 10:35:23] [info] [ 6380] Commons Daemon procrun ( 64-bit) started
[2016-09-30 10:35:23] [info] [ 6380] Starting service ‘fess-service-x64’ …
[2016-09-30 10:35:23] [info] [ 7580] Commons Daemon procrun ( 64-bit) started
[2016-09-30 10:35:23] [info] [ 7580] Running ‘fess-service-x64’ Service…
[2016-09-30 10:35:23] [info] [ 6376] Starting service…
[2016-09-30 10:35:24] [info] [ 6376] Service started in 1209 ms.
[2016-09-30 10:35:26] [info] [ 6380] Service ‘fess-service-x64’ started
[2016-09-30 10:35:26] [info] [ 6380] Start service finished.
[2016-09-30 10:35:26] [info] [ 6380] Commons Daemon procrun finished

In fess-service-x64-stderr.YYYY-MM-DD.log there are:

java.lang.IllegalStateException: Not found the webapp directory: .\src\main\webapp
at org.dbflute.tomcat.TomcatBoot.deriveWebappDir(
at org.dbflute.tomcat.TomcatBoot.prepareWebappPath(
at org.codelibs.fess.FessBoot.prepareWebappPath(
at org.dbflute.tomcat.TomcatBoot.setupWebappContext(
at org.dbflute.tomcat.TomcatBoot.prepareServer(
at org.dbflute.tomcat.TomcatBoot.go(
at org.dbflute.tomcat.TomcatBoot.bootAwait(
at org.codelibs.fess.FessBoot.main(

Is it cause ? How to resolve it ?

Hmm, the following line in service.bat may not work in your environment…

set FESS_PARAMS=-Dfess;-Dfess.home="%FESS_HOME%";"%ES_HOME%";-Dfess.home="%FESS_HOME%";-Dfess.context.path="/";-Dfess.port=8080;-Dfess.webapp.path="%FESS_HOME%\app";-Dfess.temp.path="%FESS_HOME%\temp";"%APP_NAME%";-Dfess.log.path="%FESS_HOME%\logs";-Dfess.log.level=warn;-Dlasta.env=web;

But it doesn’t give any error during service installation.

Also i installed standalone Elasticsearch service on the same server - and it works fine (as i understand elastic has similar installation scheme and service.bat file)

Can you give any guesses why “set FESS_PARAMS” doesn’t work in Windows server 2012 R2 environment?

Any ideas?

Sorry for the late response.
Fixed in Fess 10.2.2.