No results for certain words after upgrading to 14.10

Our site is in swedish and english with separate lebels for each language based on urls.

on the swedish web I do not get results if I search for the swedish word för. I also do not get a result if searching for : with a blank space and a word after.

If I search for: SCENTR: Svenskt Centrum för Hud- och Sårforskning

Then I get no results.


If i delete “för” and “SCENTR:” (e.g. Svenskt Centrum Hud- och Sårforskning) I get the result I expect.


If I only search for SCENTR: I also get the result I expect.


Searching for SCENTR: svenskt does NOT work.

Only search for the word för produces no results.

But in the System Info>Search I get results BUT no url of a html-page that belongs to the label oru_se_sv which is the label for the swedish main pages in the searches above.

We have upgraded from 13.1 to version 14.10 and I uploaded the .fess_config.bulk from old to new. In the old setup 13.1 I get results as expected but not with the 14.10.

I have tested other words in the stopwords-list with the Ö in it such as över. That works.

What has happened?

: is a special character. You need to escape it.
för is converted to for, and it’s a stop word. So, it’s not indexed.
SCENTR: Svenskt Centrum för Hud- och Sårforskning is AND queries, not a phrase query.
Therefore, "SCENTR: Svenskt Centrum för Hud- och Sårforskning" works.

Why is för converted. It’s in the swedish stopword list. I can understand why för is not indexed but not why I can’t search for anything containing it in a whole sentence.

It worked before in 13.1. What has changed?

ver: 13.1

ver 14.10:

Fess is OSS. So you can check the text analysis and the query parser. If you need more support, please contact commercial support.

Ok, but can you tell me if there can be a problem that we uploaded fess_config from 13.1 with ElasticSearch to a 14.10 with OpenSearch. I mean It worked just fine on the 13.1!

The latest version has a lot of fixes and improvements.