File Crawler

Hi Marevol,

very thanks for your fast answer.
Yesterday already I changed assignments in Json and I tried also surrounding and not surrounding numeric value with double quote:

“name”: “Goofy”,
“description”: “Goofy docs”,
“paths”: “file:/D:/Docs/Goofy”,
“numOfThread”: “5”,
“intervalTime”: “1000”,
“boost”: “100”,
“available”: “1”,
“sortOrder”: “0”,
“maxAccessCount”: “100”

but error message is the same:

“response”: {
“message”: “Num of Thread is required. intervalTime is required. Display Order is required.”,
“version”: “13.6”,
“status”: 1


Could you provide a sample command you executed to reproduce it?
ex. curl -XPUT ....

Hi Marevol,

I tried several schema for curl and this is an example:

curl -XPUT “http://localhost:8080/api/admin/fileconfig/setting/” -H “authorization: nKSbeB3Ht4h5obTphUuT4KkvYM0hbfZYGARbhxtzEfmiKaOiuw5oIrnFsa81” -H “Content-type: application/json” -d “{“name”:“Goofy”,“description”:“Goofydocs”,“paths”:“file:/D:/Docs/Goofy”,“numOfThread”:“5”,“intervalTime”:“1000”,“boost”:“100”,“available”:“1”,“sortOrder”:“0”}” -v

Also in Postman I have same error:

As I have already written in my first post the values that are indicated as missing are INTEGER and I don’t know if it is just a coincidence.

Many thanks

Hi Marevol,

I have found the solution to my problem.
Documentation says that fields name are these:

But fields not accepted I have to write like this:

numOfThread -> num_of_thread
intervalTime -> interval_time
sortOrder -> sort_order

I honestly do not know if it is a problem of documentation or of my lack of knowledge of some concepts.

Many thanks

The document is generated from source code.
The field name in the source code is Camel style, but JSON is Snake style.