fess 12.1.4 rpm not working fess 12.1.4 zip works

(from github.com/TheUnknownOtaku)
Hi,
I have same looking problem as in ticket: https://github.com/codelibs/fess/issues/1505
Fresh install Fess12 with Elasticsearch6.1.1, shows can not find this page on webpage #1505

I have replace servers realname with string “localhost”

I have Fess rpm 12.1.4, elaticsearch 6.2.4. Both are fresh installations and I have tried restarting multiple times with same results.
[root@localhost ~]# rpm -qa|grep -i elasticsearch
elasticsearch-6.2.4-1.noarch
[root@localhost ~]# rpm -qa|grep -i fess
fess-12.1.4-1.noarch

Plugins:
[root@localhost ~]# curl ‘localhost:9200/_cat/plugins’
localhost analysis-fess 6.2.1
localhost analysis-ja 6.2.1
localhost analysis-synonym 6.2.1
localhost configsync 6.2.3
localhost dataformat 6.2.3
localhost langfield 6.2.1
localhost minhash 6.2.1

[root@localhost ~]# java -version
openjdk version “1.8.0_161”
OpenJDK Runtime Environment (build 1.8.0_161-b14)
OpenJDK 64-Bit Server VM (build 25.161-b14, mixed mode)

[root@localhost ~]# curl http://localhost:9200
{
“name” : “localhost”,
“cluster_name” : “elasticsearch”,
“cluster_uuid” : “Pg6Ins0HTgm3a87DFPdg7w”,
“version” : {
“number” : “6.2.4”,
“build_hash” : “ccec39f”,
“build_date” : “2018-04-12T20:37:28.497551Z”,
“build_snapshot” : false,
“lucene_version” : “7.2.1”,
“minimum_wire_compatibility_version” : “5.6.0”,
“minimum_index_compatibility_version” : “5.0.0”
},
“tagline” : “You Know, for Search”
}
[root@localhost ~]# curl -v http://localhost:8080

GET / HTTP/1.1
Host: localhost:8080
Accept: /

< HTTP/1.1 404
< Content-Length: 0
< Date: Wed, 27 Jun 2018 16:23:14 GMT
<

  • Connection #0 to host localhost left intact
  • Closing connection #0

Weird thing is that fess works from zip package without problems but not from rpm installation.

Attached are logs:
fess.log
server_0.log

(from github.com/marevol)
Did you check elasticsearch.log?

(from github.com/TheUnknownOtaku)
elasticsearch-2018-06-27-1.log

(from github.com/marevol)
You seem to change ES_TRANSPORT_URL or fess.es.transport_addresses in config files.
It might be better to reinstall Fess.

  1. rpm -e fess
  2. rm -rf /etc/fess /usr/share/fess /var/lib/fess /var/log/fess
  3. rpm -ivh fess*.rpm
  4. systemctl start fess

(from github.com/TheUnknownOtaku)
[root@localhost ~]# yum remove fess
[root@localhost ~]# mv /etc/fess /etc/fess_old
[root@localhost ~]# mv /usr/share/fess /usr/share/fess_old
[root@localhost ~]# mv /var/log/fess /var/log/fess_old
No folder /var/lib/fess
[root@localhost ~]# yum install https://github.com/codelibs/fess/releases/download/fess-12.1.4/fess-12.1.4.rpm
[root@localhost ~]# service fess start
[root@localhost ~]# curl -v http://localhost:8080

  • About to connect() to localhost port 8080 (#0)
  • Trying ::1… connected
  • Connected to localhost (::1) port 8080 (#0)

GET / HTTP/1.1
User-Agent: curl/7.19.7 (x86_64-redhat-linux-gnu) libcurl/7.19.7 NSS/3.27.1 zlib/1.2.3 libidn/1.18 libssh2/1.4.2
Host: localhost:8080
Accept: /

< HTTP/1.1 404
< Content-Length: 0
< Date: Tue, 03 Jul 2018 07:49:22 GMT
<

  • Connection #0 to host localhost left intact
  • Closing connection #0

(from github.com/TheUnknownOtaku)
fess_03.07.2018.log
server_0_03.07.2018.log

(from github.com/marevol)
It’s better also to reinstall elasticsearch if it does not work yet…

(from github.com/TheUnknownOtaku)
Hi,
I have now also tried reinstall elasticsearch multiple times.
But still with same problems.

(from github.com/marevol)
Did you remove /var/lib/elasticsearch and /etc/elasticsearch before installing elasticsearch?

(from github.com/TheUnknownOtaku)
Problem seemed to be that our elasticsearch was installed with ansible and using project: https://github.com/elastic/ansible-elasticsearch
When we did basic elasticsearch installation from rpm fess works.