Default admin credentials not working (ES 7.7 docker compose up)

Latest docker compose config with Elasticsearch 7.7


$> docker-compose up -d
$> docker ps

CONTAINER ID        IMAGE                                   COMMAND                  CREATED             STATUS              PORTS                                        NAMES
9c2a565b5dba        codelibs/fess:snapshot                  "/bin/sh -c /usr/sha…"   16 minutes ago      Up 13 minutes       9200/tcp,>8080/tcp, 9300/tcp   fess01
5db3b845307f   "/usr/local/bin/dumb…"   16 minutes ago      Up 16 minutes>5601/tcp                       kibana
af52efb27e9f        codelibs/fess-elasticsearch:7.7.0       "/tini -- /usr/local…"   16 minutes ago      Up 16 minutes       9300/tcp,>9200/tcp             es02
e87b1b8923cb        codelibs/fess-elasticsearch:7.7.0       "/tini -- /usr/local…"   16 minutes ago      Up 16 minutes>9200/tcp, 9300/tcp             es01

When trying to use default admin credentials I am seeing the following message in the UI:

“Username or Password is not correct.”

Screen Shot 2020-05-21 at 3.18.18 PM

Did the default admin login change?

Is there a way to define the default login with docker environment variables?

Please check logs in docker-compose.

Here is a GitHub Gist That has all the logs:

0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0curl: (7) Failed to connect to es01 port 9200: Connection refused

I think the above is a cause.
I improved docker-compose.
Please remove local volumes and then start Fess:

$ docker volume rm compose_esdata01 compose_esdictionary01 compose_esdata02 compose_esdictionary02
$ docker-compose -f docker-compose.yml -f docker-compose.standalone.yml up

Thank you Shinsuke,

I did as you suggested and pulled the latest commit.

I believe there may be an issue with the network config in the docker compose files.
Specifically I am now seeing issues with Fess trying to connect to es01.


I tried a few things to debug and it appears that the Fess container (looks like its built with linuxkit) does not seem to be able to connect to any thing outside the container. I also tried running without docker-compose using:

docker run \
  -d \
  --rm \
  --name es01 \
  -e \
  -e discovery.seed_hosts=es01 \
  -e cluster.initial_master_nodes=es01 \
  -e \
  -e bootstrap.memory_lock=true \
  -e "ES_JAVA_OPTS=-Xms1g -Xmx1g" \
  -e "FESS_DICTIONARY_PATH=/usr/share/elasticsearch/config/dictionary" \
  --ulimit memlock=-1:-1 \
  --ulimit nofile=262144:262144 \
  -v esdata01:/usr/share/elasticsearch/data \
  -v esdictionary01:/usr/share/elasticsearch/config/dictionary \
  -p 9200:9200 \

docker run \
  -d \
  --rm \
  --name fess01 \
  -e "ES_HTTP_URL=http://localhost:9200" \
  -e "FESS_DICTIONARY_PATH=/usr/share/elasticsearch/config/dictionary/" \
  -p 8080:8080 \

I tested this with a GCP VM and it seems to work - I believe there is something wrong with my machine’s environment. I will verify my setup - at this time I do not think there is anything wrong with Fess new release.