SharePoint Onlineクロール時のプロキシ設定

fess-13.9.1 にて、プラグイン fess-ds-sharepoint-13.9.0.jar を使用してSharePoint Online のドキュメントライブラリ内の文書検索を計画してますが、クロールが失敗します。
会社内のイントラネット上のPCにFESSを置き、社外の SharePoint Onlineへのアクセスを行っております。
「データストアのクロール」の「SharePointDataStore」の設定項目中に、プロキシの設定項目が見当たらず、それが クロール失敗の原因の1つではないかと想像しております。
「SharePointDataStore」において、プロキシの設定をする、あるいはその代替手段はないでしょうか?

以下、参考情報です。

■ ログ情報 ( fess-crawler.log )
2020-10-21 12:54:12,151 [main] INFO Starting Crawler…
2020-10-21 12:54:12,469 [WebFsCrawler] INFO No crawling target urls.
2020-10-21 12:54:12,610 [20201021125401-1] INFO [Crawling DocLib Folder] serverRelativeUrl:/sites/▲▼/Shared Documents
2020-10-21 12:54:13,085 [20201021125401-1] ERROR Error occured. Request failure. Connection reset
org.codelibs.fess.ds.sharepoint.client.exception.SharePointClientException: Request failure. Connection reset
at org.codelibs.fess.ds.sharepoint.client.api.SharePointApi.doRequest(SharePointApi.java:76) ~[fess-ds-sharepoint-13.9.0.jar:?]
at org.codelibs.fess.ds.sharepoint.client.api.doclib.getfolder.GetFolder.execute(GetFolder.java:44) ~[fess-ds-sharepoint-13.9.0.jar:?]
at org.codelibs.fess.ds.sharepoint.crawl.doclib.FolderCrawl.doCrawl(FolderCrawl.java:54) ~[fess-ds-sharepoint-13.9.0.jar:?]
at org.codelibs.fess.ds.sharepoint.SharePointCrawler.doCrawl(SharePointCrawler.java:105) [fess-ds-sharepoint-13.9.0.jar:?]
at org.codelibs.fess.ds.sharepoint.SharePointDataStore.storeData(SharePointDataStore.java:45) [fess-ds-sharepoint-13.9.0.jar:?]
at org.codelibs.fess.ds.AbstractDataStore.store(AbstractDataStore.java:111) [classes/:?]
at org.codelibs.fess.helper.DataIndexHelper$DataCrawlingThread.process(DataIndexHelper.java:216) [classes/:?]
at org.codelibs.fess.helper.DataIndexHelper$DataCrawlingThread.run(DataIndexHelper.java:202) [classes/:?]
Caused by: javax.net.ssl.SSLException: Connection reset

■ 「データストアのクロール」の設定
「ハンドラ名」:SharePointDataStore を選択
「パラメータ」:
url=https://■■■.sharepoint.com
auth.ntlm.user=●●●●
auth.ntlm.password=●●●●●
site.name=▲▼
site.doclib_path=Shared Documents

よろしくお願いします。

現時点ですと、そのプラグインを改修しないとプロキシの設定はできないですね…。
将来のリリースで対応を検討しようとは思います。

応答ありがとうございます。
今後ともよろしくお願いいたします。