Question: Site Search not taking into account Path Mapping

I am using FileSystem Index. Path Mapping works when searching from admin and Fess Search Page, but Path Mapping doesn’t seem to work from Site Search. Are there any configurations that need to be setup to allow this?

This is what works from admin:



Also, when clicking a link on Fess Search Page it should be a url to this path:

but the link takes me to

As mentioned in another post, this link should include /fts/go instead. When I manually add this to the url, it takes me to the http url, which isn’t open to the public. If I add https, then it takes me to the correct location. It looks like the correct url is changed to the /go/ url after clicking the url.

/go link is an expected behavior to log a click action.
I think that rewriting Location response header is failed in your reverse proxy setting.

I will take a look, but the Location Response Header shouldn’t affect the Path Mapping. At least for admin and Fess search page, this works. But doesn’t work for the Site Search Javascript.

The response of /go returns url replaced by Path Mapping at Location response header.

But, does /go/ handle what shows in the list, before clicking it?

This is what Fess Search Page and admin looks like:

What is Process Type of Path Mapping?


Will this require a rebuild of fess, or is there something I can quickly change?

This needs to modify FSS JS, not Fess.
To generate a new JS file:

  1. Clone
  2. Replace with site_path in ./fss/11.4/src/templates/fess-result.hbs
  3. Run on Docker:
  4. Generate JS file

docker doesn’t install on my machine for some reason, or it is just taking too long. Any idea when this can be done in your timeline of things?

I noticed the issue has been closed, but FSS Generator doesn’t seem to have the fix yet.

Can this section of the js be changed without changing anything else, and what would it need to be changed to?

<cite>'+u((p=null!=(||(null!=n?,typeof p===c?,{name:"site",hash:{},data:o}):p))+"</cite>

Not released yet…



The actual url is still pointing to the local path.