Character mapping or word mapping does not work for me

(from github.com/PakanAngel)
I want to activate word/character mapping for my searches.
While indexing documents some characters should changed and mapped to new characters but this is not working.
How should I activate the mapping?

(from github.com/marevol)

  1. Edit mappings in Mapping List
  2. Close fess.YYYYMMDD index in Dashboard
  3. Open fess.YYYYMMDD index in Dashboard
  4. Run reindexing with Update Aliases in Upgrade

(from github.com/PakanAngel)
I am not able to follow your instructions because I tried and it failed.
I have added 2 character mappings for ي and ك. These are Arabic characters but wrongly used in many Persian documents and websites.
After closing the index I tried to reopen it but a warning pupped up to my face indicating that these characters were already added.
Then I removed them and tried several times to reopen the index and finally succeeded.
The main question is if they were already added by default why it doesn’t work.
The proof that is doesn’t work is when I search ي get different results as I search ی and similar for ك and ک.

(from github.com/marevol)

“reason”: “match “ي” was already added”

If mapping.txt is invalid, fess index cannot be opened.
For details about mapping.txt, see Lucene documents for MappingCharFilter.
For Persian, I cannot read it. Any contributions are welcome.

(from github.com/PakanAngel)
There is no Upgrade menu in my admin page. Where is it to find?