404 error after restart

(from github.com/khiraku)
Hello,
I have a problem restarting fess correctly.
I’ve installed Fess 12.1.0 using RPM and everything was working well.
But after closing the services I tried to restart them but they did not work anymore.

Thanks in advance.
fess.log
server_0.log

(from github.com/marevol)
Did you check elasticsearch.log?

Caused by: NoNodeAvailableException[None of the configured nodes are available: [{#transport#-1}{IkZ1pk9mTnOLWgry9fM1Aw}{localhost}{127.0.0.1:9300}]]

Elasticsearch does not work.

(from github.com/khiraku)
Thank you for your reply.
This is my elasticsearch.log.

elasticsearch.log

Thank you.

(from github.com/marevol)

[2018-09-28T15:53:25,713][WARN ][o.e.h.n.Netty4HttpServerTransport] [3XwE85t] caught exception while handling client http traffic, closing connection [id: 0x3d0fa6fd, L:/10.57.89.50:9200 - R:/10.57.62.64:54849]

It might be a configuration problem about your network.

(from github.com/khiraku)
Thank you for the response.

I’ve installed fess on testing environment and production environment.
On both environment, they did not work after restart.
These are logs of testing environment.

fess.log
server_0.log
elasticsearch.log

It seems they don’t say about network problem.

Acttually, I tried to access elasticsearch(servername:9200) over web browser, only on production environment.

Thanks in advance.

(from github.com/marevol)
Did you change elasticsearch.yml?
I do not think it might be correct configurations.

(from github.com/khiraku)
Exactly.
I changed elasticsearch.yml to check if elasticseach works.
After retoring settings, the sytem works correctly.
Thank you very much.